RIP was included in the CCNA exam up until 2010, because it was believed that it was no longer relevant for Cisco engineers. At the time, I thought that was a pity, but I still taught RIP to my students and included it in this study guide because it is easy to learn and configure and provides a great introduction to configuring and troubleshooting routing protocols, as well classful and classless routing.
Routing Information Protocol
RIP is based on the Bellman-Ford algorithm, and was developed by Xerox as part of their programming suite. RIP was designed for use on small- to medium-sized networks. RIP (also known as RIPv1) is classful, so it does not recognize VLSM such as 172.16.1.0/24. This makes sense because RIPv1 was first proposed in 1988 and VLSM in 1995. Because RIP does not recognize VLSM, it does not send subnet mask information with routing updates, presuming that Class A, B, and C networks have the masks /8, /16, and /24, respectively.
All routes known by RIP are gratuitously broadcast out of any RIP interface every 30 seconds (unless it breaches the split horizon rule), so even non-RIP routers receive updates and have to process the broadcast packet. There is no built-in authentication, and a 15-hop limit means that it cannot be implemented on large (modern) networks. There can be some confusion on this point in other study guides. A hop count of 16 is considered an infinite distance, and the route is therefore unreachable. This does not mean that the maximum hop count is 16, as it is actually 15. Anything above 15 hops is marked as infinity and is therefore unreachable.
With hop counts as a metric, RIP has no understanding of speed or link reliability so, as shown in Figure 14.1 below, RIP will always use the slower path to network 192.168.2.0 via R3 because the hop count is lower:
FIG 14.1 – RIP uses hop count as a metric
Figure 14.2 below shows a small network running RIP. The output below Figure 14.2 shows the hop count as the metric for various routes. Some are one hop and others are two [120/2]. The administrative distance is always 120.
FIG 14.2 – A small network running RIP
R1#show ip route
Gateway of last resort is not set
C 172.16.0.0/16 is directly connected, Serial0/0
C 192.168.5.0/24 is directly connected, Serial0/1
R 10.0.0.0/8 [120/1] via 192.168.5.2, 00:00:26, Serial0/1
[120/1] via 172.16.1.2, 00:00:11, Serial0/0
R 192.168.1.0/24 [120/1] via 192.168.5.2, 00:00:26, Serial0/1
R 192.168.2.0/24 [120/2] via 192.168.5.2, 00:00:00, Serial0/1
In the output below, it is clear that version 1 of RIP is in use because the send version is set to 1:
R1#show ip protocols
Routing Protocol is “rip”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 26 seconds
Invalid after 180 seconds, holddown 180, flushed after 240
Redistributing: rip
Default version control: send version 1, receive any version
Interface Send Recv Triggered RIP Key-chain
Serial0/0 1 1 2
Serial0/1 1 1 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
172.16.0.0
192.168.5.0
Routing Information Sources:
Gateway Distance Last Update
192.168.5.2 120 00:00:27
172.16.1.2 120 00:00:21
Distance: (default is 120)
In the screenshot below, RIP uses broadcasts (with the destination field “255.255.255.255”). Note also that it uses UDP port 520 (for the source and destination).
FIG 14.3 – RIP packet capture
RIP Operation and Timers
RIP and RIPv2 use the same operations and timers to control routing updates. The order of operations when RIP is first enabled on an interface is shown below. The timers (for all routing protocols) are shown in the show ip protocols output above. Changing the default timers should be done with great care and only after consulting Cisco TAC.
- Initialization – A request is sent out of each participating interface asking for the full routing table from all RIP routers.
- Request received – These are the response/receive messages used by RIP, which uses the hop count metric. The routing table is sent back as a response-received message.
- Response received – This message states that the routing table has been updated.
- Routing/Timers – These are invalid after 180 seconds, and every 30 seconds, the entire routing table is sent, set to unreachable at 180 seconds and flushed after 240 seconds.
- Triggered updates – These are sent if a route metric changes (not the entire table).
If no new update for a route is received after 180 seconds, it is set to 16 (unreachable). The router will advertise the metric as 16 until the flush timer removes the route from the table after 240 seconds (the invalid timer plus 60 seconds). Cisco’s version of RIP uses a holddown timer, which occurs for 180 seconds after the route is received with a higher metric. During this time, the router will not update its routing table with the update until the network has had time to converge.
The 30-second timer is subject to a random variance in Cisco IOS, so you may see update messages at 25- to 35-second intervals. These update messages prevent all routers from flooding the network with updates at the same time. The timers can be changed with the timers basic command, and then input update, invalid, holddown, and flush timers in that order. Please consult Cisco TAC first. I changed the update and invalid timers in the output below. Keep using the question mark (?) to go to the next timer to finish the string.
R1(config-router)#timers basic ?
<0-4294967295> Interval between updates
R1(config-router)#timers basic 20 ?
<1-4294967295> Invalid
R1(config-router)#timers basic 20 160
RIPv2
RIPv2 was created to address the shortcomings of RIP. RIPv2 is classless, and therefore, it sends subnet mask information in routing updates. RIPv2 supports MD5 authentication, and, instead of broadcasting, it multicasts updates to 224.0.0.9, so devices on the network not concerned with RIP events do not need to waste time de-encapsulating RIP broadcast packets only to discard them.
The output below shows the difference between RIP and RIPv2 route advertisements when the debug ip rip command is enabled:
R2#
*Mar 1 00:04:27.215: RIP: received v1 update from 192.168.1.1 on FastEthernet0/0
*Mar 1 00:04:27.215: 10.0.0.0 in 1 hops
*Mar 1 00:05:27.031: RIP: sending v1 update to 255.255.255.255 via FastEthernet0/0 (192.168.1.2)
And with RIPv2 enabled:
R2#
*Mar 1 00:06:13.311: RIP: received v2 update from 192.168.1.1 on FastEthernet0/0
*Mar 1 00:06:13.311: 10.0.0.0/8 via 192.168.1.1 in 1 hops
*Mar 1 00:06:23.771: RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (192.168.1.2)
With RIP, the update is broadcast, and there is no subnet mask information sent out. The opposite is true of RIPv2, which also sends a next-hop address with the update.
The RIPv2 screenshot in Figure 14.4 below demonstrates the fact that it multicasts but uses the same port number and protocol. It also shows the version of RIP in use.
FIG 14.4 – RIPv2 packet capture
RIPv2 is fully backward compatible with RIPv1, meaning that it can be used with routers using RIP. Each individual interface can be configured to send or receive v1 or v2 updates.
R1(config)#int f0/0
R1(config-if)#ip rip ?
receive advertisement reception
send advertisement transmission
[output truncated]R1(config-if)#ip rip send version ?
1 RIP version 1
2 RIP version 2
<cr>
RIPv2 Auto Summarization
Configuration-wise, the only difference between configuring RIP and RIPv2 is adding the version 2 command when in config-router mode (this will be covered in more detail in the labs):
R1#conf t
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 10.0.0.0
An important feature of RIPv2 is that it automatically summarizes networks at classful boundaries, so if, for example, 172.6.1.0/26 is advertised but the packet crossed the 10.0.0.0/8 network, the 172 route would be automatically summarized to 172.16.0.0/16. This feature can cause problems (but there are fixes).
Figure 14.5 below shows that the 10 network has been poorly designed. Splitting a network in this fashion is known as creating a discontiguous network or subnet and is a sign of very poor or no planning. In the topology below, R2 will try to send any traffic for the 10 network out of either interface, resulting in 50% or complete packet loss (see the output below).
This problem is solved with the no-auto summary command. Please check your IOS release to see if this has been automatically enabled or if you have to do it manually (with the show run command). In IOS 15, it appears to be turned on for RIP but off for EIGRP as per the output of the show ip protocols command below:
RIP – Automatic network summarization is in effect
EIGRP – Automatic Summarization: disabled
FIG 14.5 – Discontiguous network
In the output below, automatic summarization is in effect on R1:
R1#show ip protocols
Routing Protocol is “rip”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 18 seconds
Invalid after 180 seconds, holddown 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
Serial0/0 2 2
Loopback0 2 2
Loopback1 2 2
Loopback2 2 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
172.16.0.0
Routing Information Sources:
Gateway Distance Last Update
172.16.1.2 120 00:00:24
Distance: (default is 120)
R2 will send traffic destined for any 10 network out of either Serial interface because it does not know or understand that the 10 network is actually discontiguous, as shown in the output below:
R2#show ip route
Gateway of last resort is not set
C 172.16.0.0/16 is directly connected, Serial0/0
R 10.0.0.0/8 [120/1] via 192.168.1.2, 00:00:23, Serial0/1
[120/1] via 172.16.1.1, 00:00:10, Serial0/0
C 192.168.1.0/24 is directly connected, Serial0/1
[output truncated]When trying to ping one of the addresses on one of the networks, the ping will fail. The show ip route 10.10.30.1 command shows the source of the issue:
R2#ping 10.10.30.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.30.1, timeout is 2 seconds:
U.U.U
Success rate is 0 percent (0/5)
R2#show ip route 10.10.30.1
Routing entry for 10.0.0.0/8
Known via “rip”, distance 120, metric 1
Redistributing via rip
Last update from 172.16.1.1 on Serial0/0, 00:00:01 ago
Routing Descriptor Blocks:
192.168.1.2, from 192.168.1.2, 00:00:11 ago, via Serial0/1
Route metric is 1, traffic share count is 1
* 172.16.1.1, from 172.16.1.1, 00:00:01 ago, via Serial0/0
Route metric is 1, traffic share count is 1
The asterisk next to 172.16.1.1 shows that the next packet will use the next hop of 172.16.1.1 because RIP is load balancing over what it thinks is two links to the network. The output below resolves this issue:
R2(config)#router rip
R2(config-router)#no auto-summary
Please note that the command must be added to ALL routers concerned. Any router without the command will apply auto summarization (watch out for this in the exam). This issue is resolved with the correct networks associated with the correct interface:
R2#show ip route
Gateway of last resort is not set
C 172.16.0.0/16 is directly connected, Serial0/0
10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
R 10.10.10.0/24 [120/1] via 172.16.1.1, 00:00:06, Serial0/0
R 10.0.0.0/8 [120/1] via 192.168.1.2, 00:02:31, Serial0/1
[120/1] via 172.16.1.1, 00:01:32, Serial0/0
R 10.10.20.0/24 [120/1] via 172.16.1.1, 00:00:06, Serial0/0
R 10.10.30.0/24 [120/1] via 172.16.1.1, 00:00:06, Serial0/0
R 10.10.40.0/24 [120/1] via 192.168.1.2, 00:00:16, Serial0/1
R 10.10.50.0/24 [120/1] via 192.168.1.2, 00:00:17, Serial0/1
C 192.168.1.0/24 is directly connected, Serial0/1
R2#ping 10.10.30.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/12/24 ms
Now back over to R1 to check that automatic summarization is turned off (not in effect):
R1#show ip protocols
Routing Protocol is “rip”
Redistributing: rip
Automatic network summarization is not in effect
Maximum path: 4
[output truncated]I cannot overemphasize how important it is to grasp this concept because it is one of the few ways Cisco can try to catch you out in the exam during a hands-on configuration or troubleshooting lab.
Common commands you should be familiar with and try out when you lab up RIP are as follows:
- show ip route
- show ip protocols
- debug ip rip [database/events/trigger]
Mini-lab – Configuring RIPv2
RIPv2 is quick and easy to configure, which is why it has stood the test of time. The mini-lab below has added some of the most used commands of this protocol. Figure 14.6 below shows a simple topology:
FIG 14.6 – Mini-lab: Configuring RIPv2
Here is the configuration I added to Router 1. On Router 2, change the IP address to 10.0.0.2 and configure the hostname R2. You can add the IP addresses to all the interfaces yourself (but please ensure that you get the subnet mask values right). You only need to advertise the connected network 10.0.0.0 on R2:
R1(config)#int f0/0
R1(config-if)#ip add 10.0.0.1 255.255.255.252
R1(config-if)#int Loopback0
R1(config-if)#ip add 192.168.1.1 255.255.255.240
R1(config-if)#router rip
R1(config-router)#ver 2
R1(config-router)#network 10.0.0.0
R1(config-router)#net 192.168.1.0
Configure R2 yourself with the IP address and RIPv2 for the 10 network. You should then be able to see the 192 route as a RIP route in the table. You must add the 10 network despite the fact that it is directly connected:
R2#show ip route
Gateway of last resort is not set
10.0.0.0/30 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, FastEthernet0/0
R 192.168.1.0/24 [120/1] via 10.0.0.1, 00:00:07, FastEthernet0/0
The network has been auto summarized to /24. You can see that the AD is 120, and the network is one hop away, learned via 10.0.0.1 seven seconds before via FastEthernet0/0.
Now you need to add the no auto-summary command to R1 to prevent the 192 network from being summarized:
R1(config-router)#no auto-summary
You can wait for the routing table to update, or clear the IP routing table if you are in a hurry, and then check that the network is no longer being summarized:
R2#clear ip route *
R2#show ip route
Gateway of last resort is not set
10.0.0.0/30 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, FastEthernet0/0
192.168.1.0/28 is subnetted, 1 subnets
R 192.168.1.0 [120/1] via 10.0.0.1, 00:00:02, FastEthernet0/0
Finally, check the protocol settings on R1. Feel free to run a debug command.
R1#show ip protocols
Routing Protocol is “rip”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 17 seconds
Invalid after 180 seconds, holddown 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 2 2
Loopback0 2 2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
192.168.1.0
Routing Information Sources:
Gateway Distance Last Update
Distance: (default is 120)
[END OF MINI-LAB]Maximum Paths
Although not specifically stated in the syllabus, previous exam experience and feedback from students has shown that Cisco is notorious for slipping some subjects into the exam that are not listed in the syllabus. This makes the job of knowing what to add or leave out much harder. Some readers complain that they have been asked about a subject not covered in my book, while others complain that I have put in too much information!
By default, RIP will load balance over four equal cost paths. This is a very useful built-in feature that will, in effect, share the load over the links rather than saturate a single link.
Bear in mind that the links must be equal in order for load sharing to take effect. In the first stage, the router will choose the route with the lowest administrative distance, and if there are multiple matches, it will choose the route(s) with the lowest metric. If there is more than one equal candidate route, then it will install them (up to the maximum paths value) into the routing table. You can change this default value up to 16, as shown below (check your platform though):
R1(config)#router rip
R1(config-router)#maximum-paths ?
<1-16> Number of paths
Passive Interfaces
Passive interfaces will be covered in more detail in the EIGRP and OSPF sections. We discussed it earlier in brief, but we need to know how to configure it per protocol.
Passive interfaces are used to prevent a particular interface from taking part in the routing process. With RIP, the passive interface will receive routing updates but not send any. Adding the passive-interface X command will stop updates from being sent from the interface (in router-config mode).
If there are a large number of interfaces taking part in the routing process, the passive-interface default command can be added, and then the no passive-interface X command can be added to turn on each interface to save time (more on this later):
R1(config-router)#passive-interface ?
FastEthernet IEEE 802.3
default Suppress routing updates on all interfaces
[output truncated]Figure 14.7 below shows that RIP broadcasting is prevented on the LAN, and the 172 network is broadcast across the Serial link; in this example, the LAN-facing interface is passive:
FIG 14.7 – RIP broadcasting prevented on the LAN
R1(config-if)#router rip
R1(config-router)#net 10.0.0.0
R1(config-router)#net 172.16.0.0
R1(config-router)#passive-interface f0/0
The show ip protocols command (of which I truncated the output to save space) will reveal which interfaces are passive:
R1#show ip protocols
Routing Protocol is “rip”
Invalid after 180 seconds, holddown 180, flushed after 240
Redistributing: rip
Default version control: send version 1, receive any version
Interface Send Recv Triggered RIP Key-chain
Loopback0 1 1 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
172.16.0.0
Passive Interface(s):
FastEthernet0/0
[output truncated]Default Routes for RIPv2
Default routes save the network administrator time if all multiple end-routers use the same default path for traffic. The alternative would be to add a static route to all routers, which is very time consuming.
In Figure 14.8 below, any non-local traffic goes to R1 to be forwarded to R2, and then out to the Internet. Static routes could have been added on R3 and R4 to achieve this, but default routes save time and effort.
FIG 14.8 – Default routes
The default-information originate command was used on the gateway router (R2) to inject a default route into the RIP network.
R3#show ip route
Gateway of last resort is not set
C 172.16.0.0/16 is directly connected, FastEthernet0/0
R 10.0.0.0/8 [120/1] via 172.16.0.1, 00:00:00, FastEthernet0/0
[output truncated]A default route was configured on R1, and the default-information originate command was used to propagate this to the other routers; the Ethernet interface on R1 is 172.16.0.1:
R1(config-router)#default-information originate
R3 should now see the gateway of last resort and install it in the routing table:
R3#show ip route
Gateway of last resort is 172.16.0.1 to network 0.0.0.0
C 172.16.0.0/16 is directly connected, FastEthernet0/0
R 10.0.0.0/8 [120/1] via 172.16.0.1, 00:00:00, FastEthernet0/0
R* 0.0.0.0/0 [120/1] via 172.16.0.1, 00:00:00, FastEthernet0/0
R1 will have the gateway of last resort as the next hop address of R2:
R1#show ip route
Gateway of last resort is 10.0.0.2 to network 0.0.0.0
C 172.16.0.0/16 is directly connected, FastEthernet0/0
10.0.0.0/30 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, Serial0/0
R* 0.0.0.0/0 [120/1] via 10.0.0.2, 00:00:15, Serial0/0
Each protocol has different options available with the default-information originate command and OSPF offers always. When added the always keyword , it tells the router to advertise a default route to other routers even if you don’t have a default route in the routing table.
End of Chapter Questions
Please visit www.howtonetwork.com/ccnasimplified to take the free Chapter 14 exam.
Chapter 14 Labs
Lab1: Configure and Troubleshoot RIPv2
The physical topology is shown in Figure 14.9 below:
FIG 14.9 – Mini-lab: Configure and troubleshoot RIPv2
Lab Exercise
Your task is to configure and then troubleshoot the network above. The host and Internet cloud are there for display purposes only and will not be configured. The lab below was configured on GNS3. There is no configuration required for the switches.
Purpose
Understanding common configuration commands and issues with RIPv2 are essential to your exam success.
Lab Objectives
- Configure the network above, including all IP addresses.
- Use show commands to establish any issues present.
- Resolve issues to ensure correct routing.
- Add a default route to be injected into RIP.
- Make the LAN interface on R4 passive.
Lab Walk-through
- To configure the IP address on the routers, do the following:
R1#configure terminal
R1(config)#interface FastEthernet0/0
R1(config)#ip address 172.16.0.1 255.255.0.0
R1(config)#interface Serial0/0
R1(config)#ip address 10.0.0.1 255.255.255.252
R1(config-if)#no shut
R1(config-if)#^Z
R2:
R2#configure terminal
R2(config)#interface Serial0/0
R2(config)#ip address 10.0.0.2 255.255.255.252
R2(config-if)#no shut
R2(config-if)#^Z
R3:
R3#configure terminal
R3(config)#interface f0/0
R3(config)#ip address 172.16.0.2 255.255.0.0
R3(config-if)#no shut
R3(config-if)#^Z
R4:
R4#configure terminal
R4(config)#interface f0/0
R4(config)#ip address 172.16.0.3 255.255.0.0
R4(config-if)#no shut
R4(config)#interface f0/1
R4(config)#ip address 192.168.1.1. 255.255.255.240
R4(config-if)#no shut
R4(config-if)#^Z
Ping between a few of the devices to ensure that you have opened all the interfaces and correctly addressed them. Bear in mind that you will have no routing between networks, so you can only ping directly connected IP addresses:
R4#ping 172.16.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.1, timeout is 2 seconds:
.!!!!
- To configure routers with RIPv2, enter the following commands:
R1#configure terminal
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 10.0.0.0
R1(config-router)#network 172.16.0.0
R2#configure terminal
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 10.0.0.0
R3#configure terminal
R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#network 172.16.0.0
R4#configure terminal
R4(config)#router rip
R4(config-router)#version 2
R4(config-router)#network 172.16.0.0
R4(config-router)#network 192.168.1.0
- Now check the routing tables. You would expect auto summarization to advertise any network with the default mask, as in the R2 routing table below:
R2#show ip route
Gateway of last resort is not set
R 172.16.0.0/16 [120/1] via 10.0.0.1, 00:00:22, Serial0/0
10.0.0.0/30 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, Serial0/0
R 192.168.1.0/24 [120/2] via 10.0.0.1, 00:00:10, Serial0/0
- If you want the /28 subnet to show on R2, you must apply the no auto-summary command to more than just R4 (i.e., all the routers in between):
R4(config-router)#no auto-summary
R1(config-router)#no auto-summary
- Now check the routing table on R2 again. R3 will still be advertising the /24 network it knows about, so feel free to turn off auto summarization and then clear the routing table on R2:
R2#clear ip route *
R2#show ip route
Gateway of last resort is not set
R 172.16.0.0/16 [120/1] via 10.0.0.1, 00:00:04, Serial0/0
10.0.0.0/30 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, Serial0/0
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
R 192.168.1.0/28 [120/2] via 10.0.0.1, 00:00:04, Serial0/0
R 192.168.1.0/24 [120/2] via 10.0.0.1, 00:00:04, Serial0/0
- Now inject a default route into the RIP process, configuring only one router so that all the others receive the route and use it as the gateway of last resort:
R4#show ip route
Gateway of last resort is not set
C 172.16.0.0/16 is directly connected, FastEthernet0/0
10.0.0.0/30 is subnetted, 1 subnets
R 10.0.0.0 [120/1] via 172.16.0.1, 00:00:15, FastEthernet0/0
192.168.1.0/28 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, FastEthernet0/1
R1(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.2
R1(config)#router rip
R1(config-router)#default-information originate
R4#show ip route
Gateway of last resort is 172.16.0.1 to network 0.0.0.0
C 172.16.0.0/16 is directly connected, FastEthernet0/0
10.0.0.0/30 is subnetted, 1 subnets
R 10.0.0.0 [120/1] via 172.16.0.1, 00:00:21, FastEthernet0/0
192.168.1.0/28 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, FastEthernet0/1
R* 0.0.0.0/0 [120/1] via 172.16.0.1, 00:00:21, FastEthernet0/0
- There is no need to send RIP updates to the LAN side of R4, so make the interface passive:
R4(config)#router rip
R4(config-router)#passive-interface f0/1
R4(config-router)#end
R4#show ip protocols
Routing Protocol is “rip”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 20 seconds
Invalid after 180 seconds, holddown 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/0 2 2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
172.16.0.0
192.168.1.0
Passive Interface(s):
FastEthernet0/1
Routing Information Sources:
Gateway Distance Last Update
172.16.0.1 120 00:00:17
Distance: (default is 120)
Show Runs
hostname R1
!
interface FastEthernet0/0
ip address 172.16.0.1 255.255.0.0
duplex auto
speed auto
!
interface Serial0/0
ip address 10.0.0.1 255.255.255.252
clock rate 2000000
!
router rip
version 2
network 10.0.0.0
network 172.16.0.0
default-information originate
no auto-summary
!
ip route 0.0.0.0 0.0.0.0 10.0.0.2
– – –
hostname R2
!
interface Serial0/0
ip address 10.0.0.2 255.255.255.252
clock rate 2000000
!
router rip
version 2
network 10.0.0.0
– – –
hostname R3
!
interface FastEthernet0/0
ip address 172.16.0.2 255.255.0.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router rip
version 2
network 172.16.0.0
– – –
hostname R4
!
interface FastEthernet0/0
ip address 172.16.0.3 255.255.0.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.240
duplex auto
speed auto
!
router rip
version 2
passive-interface FastEthernet0/1
network 172.16.0.0
network 192.168.1.0
no auto-summary